Qnap TS419u port trunking with Cisco 4500

This powerful NAS (linux core inside) have 2 NICs that you can use in various mode.
I've choose to  aggregate these 2 NICs to have load balance and failover.
Through the web page go to System administration, then to network; here flag "Enable port trunking" option.
in the dropdown menu ou have to choose "IEEE 802.3ad". and apply settings.

Let's go to the cisco switch ( I have Cisco IOS, not CAT OS)
i'm assuming the two NICs are connectet to Gi1/1 and Gi1/2 (adapt to you)

interface GigabitEthernet1/1
 description to NAS
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 channel-protocol lacp
 channel-group 64 mode active
end

interface GigabitEthernet1/2
 description to NAS
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 channel-protocol lacp
 channel-group 64 mode active
end

interface Port-channel64
 description Connessione NAS
 switchport
 switchport access vlan 10
 switchport mode access
end

With this configuration on the switch, when you disconnect one NIC you will not loose connection to the NAS even if you are transferring data.

This post is also available in: Italian

Comments (5)

  1. 1:35 pm, August 30, 2010Mathew Maybee  / Reply

    Hello there, just felt the need to state how cool this blog is!

  2. 6:16 am, September 8, 2010Anonymous  / Reply

    Thanks for the tip!

    I am going to add your blog to my list!

  3. 7:28 pm, September 23, 2010Doggy  / Reply

    Hola,
    Super post, tienen que marcarlo en Digg
    Gracias

    Doggy

  4. 4:40 pm, June 2, 2011NetMann  / Reply

    Does this give better performance? Double the Speed?

    • 9:22 am, June 3, 2011Umberto  / Reply

      Think yes, because “IEEE 802.3ad” is a link aggregation protocol, but I haven’t done any test…
      If you do some tests about, please post here the results.

      Thank you

Leave a Reply


*