« Posts under Linux

WordPress redirect

Un amico (Francesco di www.flussiliberi.it) aveva il blog ospitato su un hosting free, dopo aver comprato il dominio e lo spazio mi ha chiesto un modo rapido e indolore per ridirezionare tutti i visitatori verso il nuovo blog, soprattutto quelli che raggiungevano direttamente pagine o posts.

Non so se esiste un plugin per fare ciò, ma con poche righe di php questo si può fare facilmente:

  1.  
  2. <?php
  3. $url="http://www.hacksandmore.com";
  4. if (($_GET["p"] === null) and ($_GET["page_id"] === null) and ($_GET["feed"]=== null) and ($_GET["cat"]=== null)) {
  5. $url=$url;
  6. }
  7. else
  8. {
  9. if(isset($_GET["cat"])) $url=$url."/?cat=".$_GET["cat"];
  10. if(isset($_GET["feed"])) $url=$url."/?feed=".$_GET["feed"];
  11. if(isset($_GET["p"])) $url=$url."/?p=".$_GET["p"];
  12. if(isset($_GET["page_id"])) $url=$url."/?page_id=".$_GET["page_id"];
  13. }
  14. <fieldset>
  15. <h1>Site transferred,
  16. redirect in a few seconds...</h1>
  17. <h3>WP redirect by: Umberto Bernardi
  18. <a href="http://www.hacksandmore.com">www.hacksandmore.com</a></h3>
  19. </fieldset>
  20. <script type="text/javascript"><!--mce:0--></script>
  21. ";
  22. ?>
  23.  

Potete scaricare lo script nella sezione "Downloads" a destra.

Datastore NFS per Vmware

Questo NAS Qnap ha anche il servizio NFS a bordo, quindi perchè non usarlo come datastore aggiuntivo per l'infrastruttura vmware...
Lo so, le performance non sono entusiasmanti, ma lo andremoa usare giusto per metterci le immagini CD/DVD o per creare macchine di test e backup.
Prima di tutto dobbiamo controllare che tuttli gli hosts EXS possano raggiungere il NAS.
Attensione, intendo i VMKERNEL, non la management....
Per controllarlo entriamo in ssh su tutti gli hosts e eseguiamo questo comando:

 root@esxhost# vmkping your.nas.ip

Se il ping riceve risposte siamo sulla buona strada, altrimenti le soluzioni sono 2

  • Mettere il nas sulla stessa rete dei vmkernel
  • Aggiungere un'altro vmkernel

Io ho scelto la seconda perchè i vmkernel esistenti sono usati per la Vmotion e volevo tenerli separati.
Quindi sul VI client, nell'inventory dalla vista "Hosts and Clusters", prendiamo il primo host e sotto la tab "Configuration"
scegliamo "Networking", quindi "add Networking".

Seguendo il wizard, scegliamo VmKernel, coerentemente con la nostra configurazione scegliamo il Vswitch che può comunicare con ll NAS,

Assegnamo un nome, indirizzo IP e Netmask (sulla stessa rete del NAS) alla nuova interfaccia

Clichiamo su Next e Finish.

Adesso provando il vmkping di prima dovrebbe rispondere; quindir ipetiamo gli stessi passaggi per tutti gli hosts esx presenti

Le istruzioni fornite da QNAP per l'uso con VmWare non sono corrette...gli hosts ESX possono usare l'NFS solo su TCP.
Sfortunatamente Qnap usa NFS over UDP.

Abbiamo bisogno di forzare il NASa usare NFS over TCP, ma nelle pagine di configurazione non c'è modo di fare questo...
ma... è una macchina linux quindi....connettiamoci in ssh sul NAS e editiamo il file /etc/init.d/nfs

la linea da cambiare è la #132

NO_V4="-N 4 --no-udp"

Rilanciamo il servizio NFS

/etc/initd/nfs restart

Adesso tramite l'interfaccia web impostiamo i permessi alle share che vogliamo usare.

Io permetto l'accesso completo a entrambi gli hosts ESX

So, open VI client, from inventory view choose "Hosts and Clusters" select the first Esx host and go to "configuration tab.", select "Storage" then "Add Storage".

Follow the wizard for configuration:

Select "Network File System"

Inseriamo l'ip o il nome del NAS, nel campo PATH mettiamo il nome della share che abbiamo definito prima sul NAS

Clicchiamo su Next e finish.

Ripetiamo gli steps per tutti gli ESX e abbiamo finito.

N.B.Questo howto richiede un minimo di conoscenza dell'argomento.
Non mi ritengo responsabile per problemi causati seguendo queste istruzioni.

Qnap TS419u port trunking con Cisco 4500


Questo NAS (linux inside) ha due interfacce di rete che possono essere configurate in diversi modi.

Io ho scelto di aggregare queste 2 schede per avere il bilanciamento del carico e il failover.
Attraverso la pagina web vai in amministrazione di sistema, quindi in rete; qui spunta l'opzione "Enable port trunking".
Nel menu a discesa è sufficiente scegliere "IEEE 802.3ad" e applicare le impostazioni.

Ora andiamo sullo switch cisco (io ho un Cisco IOS, non un CAT OS)...
io ho conesso le schede sulle interfacce Gi1/1 e Gi1/2 (adattatelo alla vostra situazione)

interface GigabitEthernet1/1
 description to NAS
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 channel-protocol lacp
 channel-group 64 mode active
end

interface GigabitEthernet1/2
 description to NAS
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 channel-protocol lacp
 channel-group 64 mode active
end

interface Port-channel64
 description Connessione NAS
 switchport
 switchport access vlan 10
 switchport mode access
end

Con questa configurazione sullo switch, quando una scheda viene disconnessa, la connessione al NAS resta attiva anche se stai trasferendo dei dati.

Configurare server proxy Squid con un Antivirus

In un precedente post, spiegai come configurare un asus eebox come proxy server per chaching e filtraggio contenuti...
Oggi ho aggiunto a questa macchina anche la scansione virus con HAVP( http://www.server-side.de/ ) e ClamAV ( http://www.clamav.net )
Lanciamo sulla nostra shell i comandi:

me@linuxbox# apt-get update && apt-get install havp

Ora configuriamo havp, quindi apriamo /etc/havp/havp.config e cambiamo questi valori:

PARENTPROXY localhost
PARENTPORT 8081
FORWARDED_IP true
BIND_ADDRESS 127.0.0.1
TEMPLATEPATH /etc/havp/templates/"yourlang"

Questo è sufficiente, quindi potete legger il manuale e adattare la configurazione alle vostre esigenze.

Ora editiamot /etc/squid/squid.conf e aggiungiamo le seguenti direttive:

http_port localhost:8081
acl Scan_HTTP proto HTTP
never_direct allow Scan_HTTP
cache_peer 127.0.0.1 parent 8080 0 no-query no-digest no-netdb-exchange default
cache_peer_access 127.0.0.1 allow Scan_HTTP

Ricarichiamo Squid facciamo partire HAVP e possiamo testare il funzionamento scaricando un eicar test da qui
http://www.eicar.org/anti_virus_test_file.htm