« Posts tagged cisco

Qnap TS419u port trunking with Cisco 4500

This powerful NAS (linux core inside) have 2 NICs that you can use in various mode.
I've choose to  aggregate these 2 NICs to have load balance and failover.
Through the web page go to System administration, then to network; here flag "Enable port trunking" option.
in the dropdown menu ou have to choose "IEEE 802.3ad". and apply settings.

Let's go to the cisco switch ( I have Cisco IOS, not CAT OS)
i'm assuming the two NICs are connectet to Gi1/1 and Gi1/2 (adapt to you)

interface GigabitEthernet1/1
 description to NAS
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 channel-protocol lacp
 channel-group 64 mode active
end

interface GigabitEthernet1/2
 description to NAS
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 channel-protocol lacp
 channel-group 64 mode active
end

interface Port-channel64
 description Connessione NAS
 switchport
 switchport access vlan 10
 switchport mode access
end

With this configuration on the switch, when you disconnect one NIC you will not loose connection to the NAS even if you are transferring data.

CiscoBK

This is a shell script that I've wrote in order to backup my cisco devices configuration and to keep my backup update.

Features:

  • Automatically copy configuration via tftp.
  • Compare previous configurations with new downloaded with "diff" command.
  • Send email alert if configuration change and attach to alert new and old configurations.
  • Always keep a backup copy.

Configuration:

Uncompress the archive in a place like /opt/ciscobk
Take a look to ciscobk.sh in order to correct paths according to your configuration
Open etc/ciscobk/ciscobk.conf and put ip addresses of your Cisco device
Open etc/ciscobk.mail and type here mail addresses that'll receive mail alert

HowTo configure Cisco device:

First of all I'm assuming that you know what you're doing...I'm not responsible if you destroy your running config then "wr"...
Ok, we're ready, go in enable mode and simply type

myrouter# conf t
myrouter# tftp-server nvram:startup-config
myrouter# wr

Now your Cisco device is ready to serve his configuration to anyone; I recommend to use ACL's to prevent somebody hack your router...

[dm]1[/dm]